MVC 4.5 Apps have issue with Portable Licensing 1.1.0 (Bug #142)


Added by Dmitry Efimenko about 4 years ago. Updated about 4 years ago.


Status:Rejected Start date:09/10/2013
Priority:High Due date:10/30/2013
Assignee:Daniel Nauck % Done:

0%

Category:-
Target version:1.1.1

Description

I received an email from one of the customers saying that dll Portable.Licensing 1.1.0 doesn't install on an MVC 4.5 application.
I don't have MVC 4.5 and cannot verify the issue, but if that's the case, a lot of people soon will be affected.


History

Updated by Daniel Nauck about 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Daniel Nauck

Updated by Daniel Nauck about 4 years ago

Hello,

i've only found ASP.NET MVC 4 and MVC 5 (RC1). Can you elaborate a bit with more details on that issue, e.g. error message?

What NuGet version, VS version, .NET version, etc.

  • Status changed from Assigned to Feedback
  • Assignee changed from Daniel Nauck to Dmitry Efimenko

Updated by Ryan Watson about 4 years ago

I've tried a few different project types. .net 4, .net 4.5, mvc 4, console apps.

I received this error from nuget when trying to install the package:
"Could not be installed because it is not compatible with any project in the solution. The package doesn't target any framework."

Appears that there is no spec file associated. From my browsing about it does appear I can create my own manually, but that's an unnecessary pain.

Updated by Daniel Nauck about 4 years ago

Ryan Watson wrote:

I received this error from nuget when trying to install the package:
"Could not be installed because it is not compatible with any project in the solution. The package doesn't target any framework."

What version of NuGet and VS you're using? PCL Support was added only to later versions of NuGet and maybe broken after 2.6.

Updated by Dmitry Efimenko about 4 years ago

Please see issue on GitHub [[https://github.com/DmitryEfimenko/TwitterBootstrapMvc/issues/97]]
It appears there is actually a problem of some sort.

Updated by Daniel Nauck about 4 years ago

Problem was an too old NuGet client that was unable to handle PCL libraries. (see linked github issue for further reference)

So please upgrade your NuGet to the latest version!

  • Due date set to 10/30/2013
  • Status changed from Feedback to Rejected
  • Assignee changed from Dmitry Efimenko to Daniel Nauck
  • Target version set to 1.1.1

Also available in: Atom PDF